Générateur de niveau pour Doom : Oblige

Générateur de niveau pour Doom : Oblige.

Version 2.0

1/ Répertoire de travail.

➜  ~ mkdir -p JEUX/DOOM/Editeur 
➜  ~ cd JEUX/DOOM/Editeur 
➜  Editeur 

2/ Téléchargement du code source.

➜  Editeur wget http://sourceforge.net/projects/oblige/files/Oblige/7.70/oblige-770-source.zip

3/ Décompression de l’archive.

➜  Editeur unzip oblige-770-source.zip
➜  Editeur cd Oblige-7.70-source 
➜  Oblige-7.70-source 

4/ Installation de la bibliothèque ‘fltk’.

– Répertoire de compilation :

➜  Oblige-7.70-source mkdir lib_linux
➜  Oblige-7.70-source cd lib_linux/

– Téléchargement de l’archive :

➜  lib_linux wget http://fltk.org/pub/fltk/1.3.0/fltk-1.3.0-source.tar.gz

– Décompression de l’archive :

➜  lib_linux tar xvfz fltk-1.3.0-source.tar.gz 
➜  lib_linux cd fltk-1.3.0 
➜  fltk-1.3.0  

– Configuration de la compilation :

➜  fltk-1.3.0 ./configure --quiet --disable-shared --disable-gl --disable-localjpeg --disable-localzlib --disable-localpng

– Compilation :

➜  fltk-1.3.0 make

– Installation :

➜  fltk-1.3.0 sudo make install
➜  fltk-1.3.0 sudo /sbin/ldconfig
➜  fltk-1.3.0 cd ../..

5/ Compîlation.

➜  fltk-1.3.0 make -f Makefile

6/ Lancement de Oblige.

➜  Oblige-7.70-source ./Oblige 

7/ Liens.

http://oblige.sourceforge.net/index.html
https://miniordi.hacktech.dev/generateur-de-niveau-pour-doom-oblige/